灵客

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 63|回复: 1

[探讨] 把DMI指标修改为ADX上穿ADXR条件选股公式

[复制链接]

345

主题

740

帖子

2589

积分

金牌会员

Rank: 6Rank: 6

积分
2589

优秀版主

发表于 2018-11-1 10:36:21 | 显示全部楼层 |阅读模式
(1)指标公式:

{dmiC}

MTR:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),13);

HD :=HIGH-REF(HIGH,1);

LD :=REF(LOW,1)-LOW;

DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),13);

DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),13);

PDI:=DMP*100/MTR;

MDI:=DMM*100/MTR;

D:=PDI-22;

K:=MDI-22;

A:=D-K;

STICKLINE(A>0 ,D,K,0,-1),COLORRED;

STICKLINE(A<=0,K,D,0,-1),COLORCYAN;

多:RWHITE;

空:K,COLORYELLOW;

ADX:EXPMEMA((PDI-MDI)/(MDI+PDI)*100,3),COLORMAGENTA;

ADXR:EXPMEMA(ADX,5),COLORGREEN;

趋势:EMA(ADX,13),DOTLINE,COLORGRAY;

(2)修改为条件选股公式的条件:ADX上穿ADXR.

MTR:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),13);

HD :=HIGH-REF(HIGH,1);

LD :=REF(LOW,1)-LOW;

DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),13);

DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),13);

PDI:=DMP*100/MTR;

MDI:=DMM*100/MTR;

ADX:=EXPMEMA((PDI-MDI)/(MDI+PDI)*100,3);

ADXR:=EXPMEMA(ADX,5);

CROSS(ADX,ADXR);


4

主题

224

帖子

765

积分

高级会员

Rank: 4

积分
765
发表于 2018-11-3 20:09:55 | 显示全部楼层
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

!open!

手机版|小黑屋|灵客社区
灵客外汇论坛-全国最大的外汇ea论坛交流社区

GMT+8, 2019-1-22 21:04 , Processed in 1.117316 second(s), 25 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表